Notices and Alerts

This forum publishes information about changes and updates to academic technologies.

Potential issues with Chrome Browser v.80

While using the new Chrome 80 browser, Canvas users may see error messages when trying to launch tools (such as Kaltura) inside of their sites. Users should access Canvas with a different web browser.


Use different browser

As of this post, Chrome 80 is not a supported browser. Consider installing one of the other supported browsers. Which browsers does Canvas support? 



Login to post a comment